Lyrics & Knowledge Personal Pages Record Shop Auction Links Radio & Media Kids Membership Help
The Mudcat Cafeetta

Post to this Thread - Sort Descending - Printer Friendly - Home


PermaThread: Getting Mudcat MIDIs to Play

Joe Offer 17 Mar 03 - 06:46 AM
Giac 17 Mar 03 - 07:25 AM
MMario 17 Mar 03 - 07:51 AM
GUEST,Jon 17 Mar 03 - 07:56 AM
Malcolm Douglas 17 Mar 03 - 08:17 AM
GUEST,Jon 17 Mar 03 - 08:30 AM
GUEST 17 Mar 03 - 08:34 AM
Joe Offer 18 Mar 03 - 01:03 AM
Joe Offer 25 Mar 03 - 02:34 AM
Share Thread
more
Lyrics & Knowledge Search [Advanced]
DT  Forum
Sort (Forum) by:relevance date
DT Lyrics:



Subject: Getting Mudcat MIDIs to Play
From: Joe Offer
Date: 17 Mar 03 - 06:46 AM

This is an edited PermaThread™, and all messages posted here are subject to editing and deletion.
This thread is intended to serve as a guide to helpe people troubleshoot problems they have playing MIDIs available at Mudcat

We get a lot of Help Forum requests related to problems getting the various Mudcat MIDIs to play.
If you have problems, check out these sites and see if you can get the MIDIs to play there:
If you're having problems, test these sites and then post your results here. We'll try to work out a solution that will work for everyone.
Thanks.
-Joe Offer-


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: Giac
Date: 17 Mar 03 - 07:25 AM

Hi Joe,

I've never gotten the midis to play on the new DT. I've tried each of the links above and got the following results:

Contemplator plays perfectly, as always.

After a search on JC's, when I click on the midi, I get one note and a flash of the midi play bar icon (or lack of a better term), then get bounced back to this thread.

Identical results for Yet Another ... , Mudcat Midis, and Old Mudcat Midis;

but on the last one, Man of Constant Sorrow, I don't even get the first note -- just bounced immediately back to this thread.

Sigh.
Mary


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: MMario
Date: 17 Mar 03 - 07:51 AM

I have noticed they play for me in IE but not netscape - in Netscape I have to download first.


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: GUEST,Jon
Date: 17 Mar 03 - 07:56 AM

I think in most cases when we are not looking at a bad MIDI (and there are a handful in the dt), we are looking at browser specific problems.

One thing can cause problems at the server side is the setting of the MIME type which I think should be "audio/midi".

I'm pretty sure Mudcat provides links to MIDI files but some sites are a little more complicated, e.g. at folkinfo, the link is to a .php file and the MIDI is returned using that file. In this case, I have found that MIME type needs setting in the header ("Content-type: audio/midi") but that does not satisfy all browsers as some instead of obeying the MIME type look at file extension and try to work out how to deal with a .php file. The workaround to this that works on most (but not all) other browsers is to add a further header, "Content-Disposition" to suggest a file name with a ".mid" extension.

In cases where the above fails, a user can download the .php file and rename it to .mid as what is returned to the user is a genuine MIDI file. It's just a hard job to convince some browsers of that fact.

Don't know if any of that will help here but there's no harm sharing what we have learned so far.

Jon


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: Malcolm Douglas
Date: 17 Mar 03 - 08:17 AM

Something mysterious has happened here since the upgrade; Netscape 4.7 no longer recognises the midis here or at the Mudcat Midi pages, and only offers me a "save as" option. This doesn't happen anywhere else at all (except for the occasional site which uses stupid proprietory plugin software that prevents other programs from loading perfectly normal midis; which is not the case here). I can still play midis housed elsewhere but linked to from here, of course.

IE 5.5 does better; Winamp handles midis there, and can manage everything (with the added novelty of displaying embedded lyrics, now, I notice) but IE can only access the new Midi pages if I'm logged in (I only store cookies in Netscape); if not, it returns a ColdFusion error message and I can't get to the pages in the first place.

Opera 6 behaves as IE, though I don't actually know what plays the midis. Some native plugin, presumably.


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: GUEST,Jon
Date: 17 Mar 03 - 08:30 AM

Malcolm, that sonds suspiciously like a failure to set the MIME type correctly on the server. It's a while since I looked it up but from memory, Netscape correctly looks at this but IE tends to try to use the file extension. If my understanding is correct and Mudcat offers plain .mid files. IE in dissobeying the rules will work.

Jon


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: GUEST
Date: 17 Mar 03 - 08:34 AM

this will explain a little.

Jon


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: Joe Offer
Date: 18 Mar 03 - 01:03 AM

Jon, you may have something there. In my experience, Internet Explorer is less likely to have problems with incorrect HTML, but Netscape demands that everything be proper. I guess you can't fault Netscape for that.
This MIDI thing has been plaguing a number of people for a long time, so I'm hoping we can get to the bottom of it. I have always been able to play the MIDI files at Mudcat. In the past, I clicked on the "click to play" link and the MIDI played in the background
while I looked at the lyrics.
Sometime during the past year, things changed. Now when I click on a MIDI link, the browser switches to a blank window with a Quicktime control centered on it. Or, if I'm using Windows Media Player for MIDIs, a box opens on the side of my browser. If I want to read lyrics while the MIDI is playing, I have to open the MIDI in a new window and go back to the lyrics.
-Joe Offer-


Post - Top - Home - Printer Friendly - Translate

Subject: RE: PermaThread: Getting Mudcat MIDIs to Play
From: Joe Offer
Date: 25 Mar 03 - 02:34 AM

I started this thread because somebody was having problems. He persisted, and finally came up with a solution for his problem (it may not work on yours). Here's what he says:
Every case is different, different OS, different
sound cards, etc., etc. I doubt if there is any formula, but the three things suggested (most current sound card driver, current DirectX, and making sure full duplex is enabled) are things everyone could try. The thing that turned the trick for me was going to the website and downloading the most current sound card driver. The other two solutions did not solve anything.
-Joe Offer-


Post - Top - Home - Printer Friendly - Translate
  Share Thread:
More...

Reply to Thread
Subject:  Help
From:
Preview   Automatic Linebreaks   Make a link ("blue clicky")


Mudcat time: 22 July 8:42 PM EDT

[ Home ]

All original material is copyright © 1998 by the Mudcat Café Music Foundation, Inc. All photos, music, images, etc. are copyright © by their rightful owners. Every effort is taken to attribute appropriate copyright to images, content, music, etc. We are not a copyright resource.